No ebuilds for dev-lang/mono?

I’ve tried to install Keepass, but then I get this

calculate Walter # emerge keepass
Calculating dependencies… done!

emerge: there are no ebuilds to satisfy “>=dev-lang/mono-2.10.5”.
(dependency required by “app-admin/keepass-2.34::gentoo” [binary])
(dependency required by “keepass” [argument])

However, dev-lang/mono is in the packages list.
What could be the issue?


mono is in the package list :

* dev-lang/mono
     Available versions:  2.10.9-r2^t ~ ~ {doc minimal nls pax_kernel xen ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Description:         Mono runtime and class libraries, a C# compiler/interpreter

If I try to install it :

2 [07:49:10] adrien@superlinux: ~  $ emerge -pv keepass

These are the packages that would be merged, in order:

Calculating dependencies... done!
[binary  N     ] dev-dotnet/libgdiplus-4.2-r2::gentoo  USE="cairo" 194 KiB
[ebuild  N     ] dev-lang/mono-  USE="nls (-doc) -minimal -pax_kernel -xen" ABI_X86="(64) -32 (-x32)" 83885 KiB
[binary  N     ] app-admin/keepass-2.34::gentoo  USE="-aot" 1510 KiB

Total: 3 packages (3 new, 2 binaries), Size of downloads: 85587 KiB

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Your distro is up to date ?

Run eix-sync and try again.

Well, I tried again (the system was up-to-date, I’ve re-installed the system and made eix-sync, emerge -uDN world), and this time worked…

Yes cool.
I think the first time, you didn’t do any updates and the portage database not built :slight_smile: