CLD 15.17 Установка dev-perl/Mojolicious

Здравствуйте, я новичок в Gentoo-based дистрибутивах и пытаюсь определить путь решения проблем при установке/обновлении программ. В данный момент хочу поставить пакет Mojolicious для Perl через emerge (про cpan install в курсе). И получаю данное сообщение:

user@calcvirt ~ $ emerge -pv dev-perl/Mojolicious

These are the packages that would be merged, in order:

Calculating dependencies... done!
[binary  N     ] virtual/perl-Time-Local-1.230.0-r3::gentoo  10 KiB
[ebuild  N     ] virtual/perl-Pod-Simple-3.280.0-r2::gentoo  0 KiB
[binary  N     ] dev-perl/common-sense-3.740.0::gentoo  45 KiB
[ebuild  N     ] dev-perl/Canary-Stability-2006::gentoo  4 KiB
[ebuild  N    ~] dev-perl/EV-4.220.0::gentoo  189 KiB
[ebuild     U ~] dev-lang/perl-5.24.0:0/5.24::gentoo [5.20.2:0/5.20::gentoo] USE="berkdb gdbm -debug -doc -ithreads" 13841 KiB
[ebuild  N    ~] virtual/perl-IO-Socket-IP-0.370.0-r1::gentoo  0 KiB
[ebuild  N    ~] dev-perl/Mojolicious-6.610.0::gentoo  USE="-examples -minimal {-test}" 638 KiB

Total: 8 packages (1 upgrade, 7 new, 2 binaries), Size of downloads: 14725 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:


  (dev-lang/perl-5.20.2:0/5.20::gentoo, installed) pulled in by
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-vcs/git-2.7.3-r1:0/0::gentoo, installed)
    =dev-lang/perl-5.20* required by (virtual/perl-Test-Harness-3.330.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                              
    (and 69 more with the same problems)

  (dev-lang/perl-5.24.0:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.24* required by (virtual/perl-Digest-1.170.0-r6:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                           
    (and 3 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
 # required by virtual/perl-IO-Socket-IP-0.370.0-r1::gentoo
 # required by dev-perl/Mojolicious-6.610.0::gentoo
 # required by dev-perl/Mojolicious (argument)
=dev-lang/perl-5.24.0 ~amd64
 # required by dev-perl/Mojolicious (argument)
=dev-perl/Mojolicious-6.610.0 ~amd64
 # required by dev-perl/Mojolicious-6.610.0::gentoo[-minimal]
 # required by dev-perl/Mojolicious (argument)
=dev-perl/EV-4.220.0 ~amd64
 # required by dev-perl/Mojolicious-6.610.0::gentoo
 # required by dev-perl/Mojolicious (argument)
=virtual/perl-IO-Socket-IP-0.370.0-r1 ~amd64

# Правильно ли я понимаю, что у меня одновременно требуется установка perl 5.20 и 5.24 из-за пакета Mojolicious?
# Удивляет, что virtual/perl-Digest-1.170.0-r6:0/0::gentoo, требующий 5.24, уже установлен - это как?
# Какой наилучший путь решения?
# Какие keyword записать по итогу?
# Имеет ли смысл сделать отдельный ebuild скрипт на основе старого тэга Mojolicious с гитхаба, совместимого с perl 5.20?

в /usr/portage/virtual/perl-IO-Socket-IP/perl-IO-Socket-IP-0.370.0-r1.ebuild

    || ( =dev-lang/perl-5.24* =dev-lang/perl-5.22* ~perl-core/${PN#perl-}-${PV} )

вот он за собой и тянет.

в perl-IO-Socket-IP-0.290.0.ebuild зависимость от =dev-lang/perl-5.20*, так что решением будет замаскировать virtual/perl-IO-Socket-IP версии выше 0.290

ну или полностью апдейтить в системе perl на 5.22, это кстати вполне нормальная идея.