Calculate Forum

Обновление CL XFCE

Обновление пакетов
 * Вычисление зависимостей ...                                                                [ ok ]
[binary  N     ] sys-power/acpid-2.0.31::gentoo  USE="(-selinux)" 86 KiB
[binary     U  ] sys-apps/ethtool-5.3::gentoo [5.1::gentoo] 174 KiB
[binary  N     ] media-gfx/xfce-themes-calculate-18::calculate  230 KiB
[binary  N     ] media-libs/shaderc-2018.0::gentoo  USE="-doc -test" ABI_X86="(64) -32 (-x32)" 185 KiB
[binary     U  ] dev-libs/libassuan-2.5.3::gentoo [2.5.1::gentoo] USE="-static-libs" 123 KiB
[binary  N     ] x11-libs/libXpresent-1.0.0-r1::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 43 KiB
[binary     U  ] dev-db/sqlite-3.29.0:3::gentoo [3.28.0:3::gentoo] USE="readline secure-delete -debug -doc -icu -static-libs -tcl -test -tools" ABI_X86="32 (64) (-x32)" 1514 KiB
[binary     U  ] dev-lang/python-3.6.9:3.6/3.6m::gentoo [3.6.5:3.6/3.6m::gentoo] USE="bluetooth%* gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -examples -hardened -libressl -test -tk -wininst" 25110 KiB
[binary     U  ] net-misc/youtube-dl-2019.09.28::gentoo [2019.09.12.1::gentoo] PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)" 8151 KiB
[binary     U  ] sys-apps/iproute2-5.3.0::gentoo [5.2.0-r1::gentoo] USE="berkdb caps iptables ipv6 -atm -elf -minimal (-selinux)" 1111 KiB
[binary     U  ] xfce-base/libxfce4util-4.14.0:0/7::gentoo [4.13.2:0/7::gentoo] USE="introspection -vala" 203 KiB
[binary     U  ] net-fs/nfs-utils-2.4.1-r2::gentoo [2.4.1-r1::gentoo] USE="caps ipv6 libmount nfsidmap nfsv4 tcpd uuid -junction -kerberos -ldap -nfsdcld -nfsv41 (-selinux)" 468 KiB
[ebuild     U  ] net-nds/openldap-2.4.48::gentoo [2.4.45::gentoo] USE="berkdb crypt ipv6 sasl ssl syslog tcpd -cxx -debug -experimental -gnutls -iodbc -kerberos -kinit -libressl -minimal -odbc -overlays -pbkdf2 -perl -samba (-selinux) -sha2 -slp -smbkrb5passwd -static-libs -test%" ABI_X86="32 (64) (-x32)" 5572 KiB
[binary     U  ] net-print/epson-inkjet-printer-escpr-1.7.2::gentoo [1.6.33::gentoo] 1442 KiB
[binary     U  ] net-analyzer/nmap-7.80::gentoo [7.70::gentoo] USE="ipv6 nls nse ssl -libressl -libssh2 -ncat -ndiff -nmap-update -nping (-system-lua) -zenmap" PYTHON_TARGETS="python2_7" 5673 KiB
[binary     U  ] sys-apps/inxi-3.0.36.1::gentoo [3.0.34.1::gentoo] USE="bluetooth opengl -hddtemp" 183 KiB
[binary   R    ] x11-libs/gdk-pixbuf-2.38.1:2::gentoo  USE="X introspection jpeg tiff -gtk-doc (-jpeg2k%)" ABI_X86="32 (64) (-x32)" 843 KiB
[binary   R    ] dev-qt/qtimageformats-5.12.3:5/5.12::gentoo  USE="-debug -mng -test (-jpeg2k%)" 71 KiB
[binary   R    ] media-libs/libraw-0.19.3:0/19::gentoo  USE="jpeg lcms openmp -examples (-jpeg2k%)" ABI_X86="(64) -32 (-x32)" 582 KiB
[ebuild     U  ] www-client/vivaldi-2.8.1664.40_p1::gentoo [2.7.1628.33_p1::gentoo] L10N="ru -am -ar -be -bg -bn -ca -cs -da -de -el -en-GB -en-US -eo -es -es-419 -es-PE -et -eu -fa -fi -fil -fr -fy -gl -gu -he -hi -hr -hu -hy -id -io -is -it -ja -jbo -ka -kn -ko -ku -lt -lv -mk -ml -mr -ms -nb -nl -nn -pl -pt-BR -pt-PT -ro -sc -sk -sl -sq -sr -sv -sw -ta -te -th -tr -uk -vi -zh-CN -zh-TW" 61094 KiB
[binary     U  ] app-crypt/gpgme-1.13.0-r1:1/11::gentoo [1.13.0:1/11::gentoo] USE="cxx qt5 -common-lisp -python -static-libs" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)" 901 KiB
[binary   R    ] media-libs/devil-1.7.8-r2::gentoo  USE="X gif jpeg mng openexr opengl png sdl tiff -allegro -glut -nvtt -static-libs -xpm (-jpeg2k%)" CPU_FLAGS_X86="sse sse2 sse3" 361 KiB
[ebuild   R    ] x11-drivers/nvidia-drivers-435.21:0/435::gentoo  USE="X acpi* compat driver gtk3 kms multilib tools uvm (-libglvnd) -static-libs -wayland" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] media-video/mpv-0.29.1-r1::gentoo [0.27.2::gentoo] USE="X alsa cdda cli drm dvd egl iconv jpeg libass libmpv lua openal opengl pulseaudio sdl uchardet v4l vaapi vdpau vulkan%* xv zlib (-aqua) -archive -bluray (-coreaudio) -cplugins (-cuda) -doc -dvb -gbm -jack -javascript -lcms -libcaca -luajit -oss (-raspberry-pi) -rubberband -samba (-selinux) -test -tools -wayland -zsh-completion (-encode%*) (-libav%)" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)" 3089 KiB
[binary   R    ] media-libs/opencv-3.4.1-r6:0/3.4.1::gentoo  USE="eigen ffmpeg gphoto2 gstreamer gtk ieee1394 jpeg openexr opengl openmp png python qt5 threads tiff v4l vaapi webp (-contrib) (-contrib_cvv) (-contrib_dnn) (-contrib_hdf) (-contrib_sfm) (-contrib_xfeatures2d) (-cuda) -debug -dnn_samples -examples -gdal (-gflags) (-glog) -java -lapack -libav -opencl -pch (-tesseract) -testprograms (-vtk) -xine (-jpeg2k%)" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse sse2 sse3 -avx -avx2 -fma3 -popcnt -sse4_1 -sse4_2 -ssse3" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)" 8284 KiB
[binary   R    ] media-libs/gegl-0.4.16:0.4::gentoo  USE="cairo ffmpeg introspection openexr pdf raw sdl svg tiff v4l webp zlib -debug -lcms -lensfun -libav -test -umfpack -vala (-jpeg2k%)" CPU_FLAGS_X86="mmx sse" 2653 KiB
[ebuild     U  ] www-client/firefox-bin-69.0.2::gentoo [69.0::gentoo] USE="ffmpeg pulseaudio (-selinux) -startup-notification" L10N="ru -ach -af -an -ar -ast -az -be -bg -bn -br -bs -ca -cak -cs -cy -da -de -dsb -el -en-CA -en-GB -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -ia -id -is -it -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mk -mr -ms -my -nb -nl -nn -oc -pa -pl -pt-BR -pt-PT -rm -ro -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -ur -uz -vi -xh -zh-CN -zh-TW" 65088 KiB
[binary     U  ] www-client/midori-9.0::gentoo [7.0::gentoo] 1012 KiB
[binary     U  ] sys-apps/portage-2.3.76::gentoo [2.3.69::gentoo] USE="(ipc) native-extensions xattr -build -doc -epydoc -gentoo-dev -rsync-verify (-selinux)" PYTHON_TARGETS="python2_7 python3_6 (-pypy) -python3_5 (-python3_7)" 5125 KiB
[binary     U  ] app-portage/gentoolkit-0.4.6::gentoo [0.4.5::gentoo] PYTHON_TARGETS="python2_7 python3_6 (-pypy) -python3_5 (-python3_7)" 6655 KiB
[blocks b      ] <app-portage/gentoolkit-0.4.6 ("<app-portage/gentoolkit-0.4.6" is blocking sys-apps/portage-2.3.76)
[binary     U  ] sys-apps/calculate-utils-3.6.4.8:3::calculate [3.6.4.7:3::calculate] USE="backup client console dbus desktop gpg install qt5 -minimal -pxe (-server)" PYTHON_TARGETS="python2_7" 2620 KiB
[binary     U  ] xfce-base/xfconf-4.14.1:0/3::gentoo [4.12.1-r1:0/0::gentoo] USE="introspection%* -debug -perl -vala%" 292 KiB
[binary     U  ] xfce-base/libxfce4ui-4.14.1::gentoo [4.13.4::gentoo] USE="gtk2%* introspection -debug -glade -startup-notification -vala" 450 KiB
[binary     U  ] xfce-base/exo-0.12.8::gentoo [0.12.4::gentoo] USE="-gtk2%" 866 KiB
[binary     U  ] xfce-base/garcon-0.6.4-r1::gentoo [0.6.2-r1::gentoo] USE="gtk2" 240 KiB
[binary     U  ] xfce-base/xfwm4-4.14.0-r1::gentoo [4.12.5-r1::gentoo] USE="opengl%* xcomposite xpresent%* -startup-notification (-dri%*)" 789 KiB
[binary     U  ] xfce-base/xfce4-session-4.14.0::gentoo [4.12.1-r2::gentoo] USE="nls policykit -elogind (-systemd) -xscreensaver (-upower%*)" 521 KiB
[binary     U  ] x11-terms/xfce4-terminal-0.8.8::gentoo [0.8.7.4::gentoo] USE="-utempter" 669 KiB
[binary     U  ] xfce-base/xfce4-panel-4.14.1::gentoo [4.12.2::gentoo] USE="gtk2%* introspection%* -vala%" 1107 KiB
[blocks b      ] <xfce-base/xfce4-panel-4.13.1 ("<xfce-base/xfce4-panel-4.13.1" is blocking xfce-base/xfconf-4.14.1)
[binary     U  ] xfce-base/xfce4-settings-4.14.1::gentoo [4.12.4-r1::gentoo] USE="libnotify upower xklavier -colord% -libcanberra" INPUT_DEVICES="libinput" 891 KiB
[blocks b      ] <xfce-base/xfce4-settings-4.13.1 ("<xfce-base/xfce4-settings-4.13.1" is blocking xfce-base/xfconf-4.14.1)
[binary     U  ] xfce-base/xfce4-appfinder-4.14.0::gentoo [4.12.0-r2::gentoo] 240 KiB
[binary     U  ] xfce-base/thunar-1.8.9:0/3::gentoo [1.6.16-r1:0/0::gentoo] USE="exif introspection%* libnotify pcre trash-panel-plugin udisks -test (-dbus%*)" 1909 KiB
[binary     U  ] xfce-extra/xfce4-notifyd-0.4.4::gentoo [0.4.3-r1::gentoo] 225 KiB
[binary     U  ] xfce-extra/xfce4-power-manager-1.6.5::gentoo [1.6.1::gentoo] USE="networkmanager panel-plugin policykit (-debug%)" 932 KiB
[binary     U  ] xfce-extra/xfce4-datetime-plugin-0.8.0::gentoo [0.7.0::gentoo] 50 KiB
[ebuild     U  ] xfce-extra/xfce4-sensors-plugin-1.3.92-r1::gentoo [1.3.0-r1::gentoo] USE="acpi hddtemp libnotify lm-sensors" VIDEO_CARDS="-nvidia" 467 KiB
[binary     U  ] xfce-extra/xfce4-screenshooter-1.9.6::gentoo [1.9.5::gentoo] 282 KiB
[binary     U  ] xfce-extra/xfce4-netload-plugin-1.3.2::gentoo [1.3.1::gentoo] 107 KiB
[binary     U  ] xfce-extra/thunar-volman-0.9.5::gentoo [0.8.1-r2::gentoo] USE="libnotify" 210 KiB
[binary     U  ] xfce-extra/tumbler-0.2.7::gentoo [0.2.3::gentoo] USE="ffmpeg gstreamer jpeg pdf raw -curl -odf" 261 KiB
[binary     U  ] xfce-base/xfdesktop-4.14.1::gentoo [4.12.4::gentoo] USE="libnotify thunar -debug" 1229 KiB
[binary     U  ] xfce-extra/thunar-media-tags-plugin-0.3.0::gentoo [0.2.1-r1::gentoo] 101 KiB
[binary     U  ] xfce-extra/thunar-archive-plugin-0.4.0::gentoo [0.3.1-r3::gentoo] 88 KiB
[binary     U  ] xfce-base/xfce4-meta-4.14-r1::gentoo [4.12-r1::gentoo] USE="svg upower%* -minimal" 12 KiB
 * 54 пакетов будет установлено, 220556 KiB будет загружено

  (xfce-base/xfconf-4.12.1-r1:0/0::gentoo, installed) pulled in by
    >=xfce-base/xfconf-4.12.1:0/0= required by (xfce-extra/xfce4-xkb-plugin-0.8.1:0/0::gentoo, installed)
                             ^^^^^                                                                                                           
    (and 1 more with the same problem)

xfce-base/exo:0

  (xfce-base/exo-0.12.8:0/0::gentoo, binary scheduled for merge) pulled in by
    >=xfce-base/exo-0.12.8 required by (xfce-base/xfce4-meta-4.14-r1:0/0::gentoo, binary scheduled for merge)
    ^^              ^^^^^^                                                                                                                                          

  (xfce-base/exo-0.12.4:0/0::gentoo, installed) pulled in by
    <xfce-base/exo-0.12.5-r100:= required by (app-cdr/xfburn-0.5.5-r1:0/0::gentoo, installed)
    ^              ^^^^^^^^^^^ ^                                                                                                                                       
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
 * Выполнение Emerge завершилось с ошибкой
 * Не удалось обновить

Кое-как обновил CL после удаления xfburn.
Чем не угодил xfburn и что не так с xfce-base/exo?

emerge -av app-cdr/xfburn

Local copy of remote index is up-to-date and will be used.

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[binary  N     ] dev-libs/libburn-1.5.0::gentoo  USE="-debug -static-libs" 446 KiB
[binary  N     ] dev-libs/libisofs-1.5.0::gentoo  USE="acl xattr zlib -debug -static-libs -verbose-debug" 318 KiB
[binary     UD ] xfce-base/exo-0.12.4::gentoo [0.12.8::gentoo] USE="(-gtk2%)" 945 KiB
[binary  N     ] app-cdr/xfburn-0.5.5-r1::gentoo  USE="gstreamer udev" 577 KiB

Total: 4 packages (1 downgrade, 3 new, 4 binaries), Size of downloads: 2285 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

xfce-base/exo:0

  (xfce-base/exo-0.12.4:0/0::gentoo, binary scheduled for merge) pulled in by
    <xfce-base/exo-0.12.5-r100:0/0= required by (app-cdr/xfburn-0.5.5-r1:0/0::gentoo, binary scheduled for merge)
    ^              ^^^^^^^^^^^^^^^^                                                                                                                                                        

  (xfce-base/exo-0.12.8:0/0::gentoo, installed) pulled in by
    >=xfce-base/exo-0.12.8 required by (xfce-base/xfce4-meta-4.14-r1:0/0::gentoo, installed)
    ^^              ^^^^^^                                                                                                                         


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

USE="-gtk2%" Наверное оно мешает XFCE перешло же на gtk3

Есть такая тема - последний доступный в репозитории xfburn требует старую версию exo (xfce). Если хотите оболочку обновить - тогда пока прийдется xfburn снести. Как альтернативу могу предложить graveman или tkdvd. А еще прийдется снести старые плагины к xfce - будьте готовы, если пользуетесь ими.

Можно, конечно, подправить ebuild и попробавть таки поставить после этого xfburn обратно, пересобрав из локального оверлея. Но что-то я подозреваю, что зависимость эта там стояла не просто так и сходу ничего из этого не выйдет. А править исходники - это уже, как по мне, перебор.

Если же xfburn вам нужен принципиально - тогда обновить xfce не выйдет. Можете временно, пока xfburn не обновят, замаскировать все новые xfce-пакеты чтобы emerge не мозолил глаза этой проблемой и обновлял пока что может.

Ладно, буду по старинке крутить болванки через cdrecord.
Для полной уверенности в себе не помешали бы dvdrecord и wodim.

Все хотел сказать об оформлении в CLDX.
На мой взгляд ранее 3-4 года назад оформление/стиль по умолчанию был более соответствующим, а сейчас такой контраст выглядит вычурным что ли. Бежевые папки на сине-черно-белом фоне смотрятся нелепо.
Список стилей большой, но между ними нет никакой разницы. Стоит отметить только Calculate, Crux, Adwaita Adwaite dark и на этом всё. Зачем нужны остальные мне непонятно. Отличия принципиального нет.

5

1 Like

Оперативно сработали. Установил xfburn.

сегодня cldx обновил, на интерфейсе окон появились артефакты, передергивание темы это убирает. Еще у кого такое есть?

    lspci -k | grep -A3 -i vga
    01:00.0 VGA compatible controller: NVIDIA Corporation G84 [GeForce 8600 GT] (rev a1)
	Subsystem: Gigabyte Technology Co., Ltd G84 [GeForce 8600 GT]
	Kernel driver in use: nouveau
	Kernel modules: nouveau, nvidia_drm, nvidia

    cl-setup-video --video list
    Видео драйвер:
    [default]  Автоопределение системой
    [nouveau]  Nvidia Nouveau (nouveau) *
    [nvidia]   Nvidia Graphics Driver (nvidia)

Что-то подобное было. Возможно в логах найдется намек или xorg.conf надо править.
Нуво лучше не использовать. С воспроизведением видео будут проблемы.
Nvidia перестал поддерживать GeForce 8600 GT. Последний доступный драйвер 340.107 от 2018.6.6.

Mastodon Mastodon